CHOP CULT HOME
Email Password
Search

Thread: Post break in

Hybrid View

  1. #1

    Default Post break in

    Hey guys & gals

    I had my 1974 shovel rebuilt from top to bottom earlier this year by a well known old school big twin mech in my area. He wanted me to return to see him once I finished running it in to work on it.

    Iíve just finished putting the break in miles on it but Iíve since moved interstate so I canít go see him. I was just wanting to get some info on any post run in procedures? Am I just re torquing and checking the timing ? I dropped the oil a few times while running her in and adjusted the carb a little that it needed.

    Thanks in advance !

  2. #2

    Join Date
    Sep 2012
    Posts
    12,407

    Default

    How many miles do you have on it??????

  3. #3

    Default

    I assume you re-torqued the heads ( 65 lbs.) after the First start-up and total Cool-down. You should not have to re-torque ever again. Once timing is set it never needs to be checked again Unless it has been messed with unless it's points.

    After First start up and total cool down I also check the lifters if they're solids. They Often need re-adjust.
    For the first couple hundred miles I also re-check ALL the mounting bolts to EVERYTHING. Motor mounts, trans mounts, all exhaust brackets and that stupid One exhaust bolt to the head.
    Also the Carb mounting bracket and the manifold - head connections. And don't hesitate to spray the Manifold seals ( o-ring or rubber-band ) with card cleaner -- always from Right to Left to check for intake leaks.
    Of course you always want to keep an eye n' ear open to any and all potential probs during first few hundred and "lifetime".
    If the Re-install was done correctly these minimal checks are all you should need to perform.
    Have a Ball

Share This



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in