CHOP CULT HOME
Email Password
Search
  1. #1

    Default Electrical? Custome wiring harness.

    Whatís up guys

    I have a chopped 2001 sportster 1200 c

    I recently bought the Sportster Treatment custom wiring harness for my bike.

    Details-my bike already had all the blinkers gauges and sensors eliminated. The OG harness was still there. Extra wires and all.

    So i went step by step from the video and the install booklet.

    Everything is hooked up correctly (?) everything is grounded correctly (?)

    The battery is providing power.

    When I turn the key nothing happens. No lights. No attempted turn over. Nothing. The circuit breaker does not arc when connected. But the battery does.

    Iíve included the video provided by lowbrow if anyone cares to watch it to have some idea of whatís going on.


    https://www.lowbrowcustoms.com/blogs...son-sportsters

  2. #2
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    May 2019
    Posts
    1,026

    Default

    Did they include a wiring diagram?


    Can you follow it to your ignition switch and see if you have power there?

  3. #3
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Sep 2012
    Posts
    12,226

    Default

    A test light is your new friend............

  4. #4

    Join Date
    Dec 2018
    Posts
    1,910

    Default

    Quote Originally Posted by Tattooo View Post
    A test light is your new friend............
    ^ +++ ^

    Jim

  5. #5

    Default

    Have you got a TSM or TSSM on your bike. I cant remember what year they started to put TSSMs on them but i know your loom wont work if it has security on it.

  6. #6

    Default

    Quote Originally Posted by 93trident View Post
    Have you got a TSM or TSSM on your bike. I cant remember what year they started to put TSSMs on them but i know your loom wont work if it has security on it.
    thanks for the awesome information.

  7. #7

    Default

    Quote Originally Posted by 93trident View Post
    Have you got a TSM or TSSM on your bike. I cant remember what year they started to put TSSMs on them but i know your loom wont work if it has security on it.
    2001 doesn't have a security function in the turn signal unit. The Sportster treatment kit deletes turn signals from the system.

    I'd recommend reaching out to the guy who makes those Sportster Treatment kits, his IG is @apeknuckles_harnesses

    My recommendation would be to disconnect all leads near the battery, and re-check you have the right leads connected to the right places. Battery has power which is good, which makes me think the key switch wires got connected wrong, or the main circuit breaker is faulty/connected wrong. Get a multimeter out there and start tracing power from the battery forward to find where you're losing the connection.

Share This



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in