CHOP CULT HOME
Email Password
Search
  1. #1

    Default Need Schematic on Titan Handlebar with Electronic Integrated Gauge

    I have this custom and unique setup on my Titan handlebars. Unfortunately I have no schematic to wire it. Any assistance would be greatly appreciated. Click image for larger version. 

Name:	F3D9C20A-B49B-4A24-943E-FF9170D58AA5.jpg 
Views:	3 
Size:	99.0 KB 
ID:	104038

  2. #2
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Sep 2012
    Posts
    12,178

    Default

    Quote Originally Posted by Smileyz51 View Post
    I have this custom and unique setup on my Titan handlebars.
    Yes you sure do.... Was it on there to start with or are you adding it????????? You didn't say.......

  3. #3

    Default

    It was already on the bike when I bought it.

  4. #4
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Sep 2012
    Posts
    12,178

    Default

    Quote Originally Posted by Smileyz51 View Post
    It was already on the bike when I bought it.
    So it was never wired or it stopped working????????? You didn't say.......

  5. #5

    Default

    Quote Originally Posted by Tattooo View Post
    So it was never wired or it stopped working????????? You didn't say.......
    It wasnít working when I bought it but I had a guy go through the bike and replace all the wiring. Wiring was brittle and had some other issues.
    We decided to keep the Titan bars with display because it is so unique. However, my guy said he did all he could with the Titan display, which is get the lights going and had the odometer displays (speedometer doesnít display). A light bar at the top displayS but , I have no idea what it is for, it isnít a tach and I hope it isnít a engine temp display.
    Guy said if I get the schematic he can repair even more issues.

  6. #6
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Apr 2013
    Posts
    9,232

    Default

    If no joy you could probably find a GPS speedometer (bicycles use them) or other interesting object or cover plate to fill the space. Does the odometer register mileage? Is there an unused wire or wires etc hanging off the back? I suggest posting a rear pic in case a Titan owner recognizes it as there may have been more than one version.

  7. #7

    Default

    Great points! The Odometer doesn’t register new miles and I use my Waze app to monitor speed.

  8. #8
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Sep 2012
    Posts
    12,178

    Default

    If it was working before the guy rewired it he is the one the fucked it up..... He should have found out where things went before he started taking wires off......

  9. #9
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Apr 2013
    Posts
    9,232

    Default

    If the odometer doesn't update it either needs pulses from the speed sensor (do you have one?), the speed sensor may be dead (not uncommon and the original is now old), or it may not be connected. The speedo COULD be damaged but it makes sense to eliminate the sensor first.

    https://www.v-twinforum.com/threads/...esting.384769/ may help.

Share This



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in