CHOP CULT HOME
Email Password
Search
  1. #1

    Join Date
    Jul 2018
    Posts
    24

    Default Ultima Ignitions: Good or Bad?

    So I'm nearing the end of my Sporty build and it's time to get a good ignition setup. I want to run a VOES switch because it seems like that's the most reliable way to go about it. I found this Ultima set, but not familiar with the brand and haven't found anyone else who is either. The reviews seem good, but I'd like to know if someone has run an Ultima kit long-term. I'll fork over the coin for the Dyna if I need to, but if I can get by with this and it won't fail in 6 months then I'd rather do that.

    Thoughts?

    https://www.ebay.com/itm/Ultima-Prog...53.m1438.l2649

  2. #2
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Sep 2012
    Posts
    12,163

    Default

    SHITTY....................... Anything Ultima......................

  3. #3
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jun 2016
    Posts
    107

    Default

    When the Ultima came out I was curious about it - some said it was made by Dyna and is a copy of the Dyna 2000i. I contacted Dyna and they told me that they build the unit to Ultima specs. They could not get into detail due to non-disclosure etc. I believe that the difference is that Ultima specifies lower reliability parts.

    I've installed a few in shovels and evos and the seem to work fine, had no returns - but I can't speak for the long term reliability. I can tell you that I've been running a Dyna 2Ki in my daily rider shovelhead for 8 years and many thousands of miles with no issues - truly a set and forget unit. This is in a harsh environment - Mojave dessert year around so if it were going to fail from heat this is probably the place for that failure to occur.

    Ultima products are a crap-shoot. Some are fine, some are shit.

    I've built several motors using the Ultima replacement engine cases with absolutely no issues. Both evo and cone shovel have been fine. Out of nine sets we had problems with two - hairline crack from cam bearing bore to crank bearing insert. No problem on the swap - Ultima paid freight both ways and sent replacement before receiving bad case. I don't hesitate to use this particular Ultima product.

    The Ultima Carb (S&S E copy) is a piece of shit in my experience. Machining is very poor, hard to tune, and wont hold a tune due to sloppy fit of the idle mixture screw. Stick with S&S.

    Same issues with the Ultima oil pumps - loose tolerances and poor QC on the machining make for real hit or miss performance. Stick with S&S.

    I don't use Ultima parts on my personal motorcycle - but everyone has a budget and on the road with an Ultima part is better than parked in the garage. To ride is the thing.

    I don't know anyone who looks at their motorcycle and says "Boy I sure wish I had used lower quality parts on this bike".

    Just my experience - your mileage may vary.

  4. #4
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Sep 2009
    Posts
    1,037

    Default

    I will give you some experience I know from guys that used or use them. They say the ignition isn’t bad but the coil that comes with it is a hunk of crap.

    I personally have a ultima six speed transmission in one of my bikes. I have no real complaints except that the shifter pawl spring broke at about 20 thousand miles.

  5. #5

    Join Date
    Jul 2018
    Posts
    24

    Default

    Thanks for the info guys, good stuff to know.

  6. #6
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Mar 2014
    Posts
    340

    Default

    My experience:

    The Ultima in the 77 Ironhead I had was flawless for years.... to include the notorious coil it came with.

    The 2000i in my shovelhead was also 99% flawless. I say 99% because the status light bulb on it failed on me making it unable to static time...

    Wouldn't hesitate to run either.

Share This



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in