CHOP CULT HOME
Email Password
Search
  1. #1

    Join Date
    Dec 2019
    Posts
    1

    Default 1200 Bandit K2 No Spark!

    We have a Suzuki GSF 1200 Bandit K2 2001 - 2005

    We have made a new wiring harness from scratch using a Moto-gadget M-unit.
    We have removed the side stand / clutch switch / kill switch circuit.
    We cant get a spark.
    Has anyone done this before? Do you have a wiring diagram using an M-unit we could take a look at please?
    Or any help in general would be greatly appreciated.
    Many thanks

  2. #2
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Sep 2012
    Posts
    11,761

    Default

    Quote Originally Posted by string View Post
    Has anyone done this before? Do you have a wiring diagram using an M-unit we could take a look at please?
    We have removed the side stand / clutch switch / kill switch circuit.
    Can you post a pic of the wiring diagram that you used to wire your bike?????

    What did you do with the wires to the kill switch when you did away with them?????

    Thanks
    Last edited by Tattooo; 02-15-2020 at 7:12 AM.

  3. #3
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Dec 2017
    Posts
    2,436

    Default

    MotoGadget M-Unit Wiring

    "...the MotoGadget M-Unit. This intelligent device functions as a new heart of your motorcycle wiring harness and works both for noobs (just like me) and for the pro’s and everybody in between. In this article I’ll give you some handouts for the MotoGadget M-Unit wiring."

    https://bikebrewers.com/motogadget-m-unit-wiring/

  4. #4
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    May 2012
    Posts
    35

    Default

    Quote Originally Posted by string View Post
    We have a Suzuki GSF 1200 Bandit K2 2001 - 2005

    We have made a new wiring harness from scratch using a Moto-gadget M-unit.
    We have removed the side stand / clutch switch / kill switch circuit.
    We cant get a spark.
    Has anyone done this before? Do you have a wiring diagram using an M-unit we could take a look at please?
    Or any help in general would be greatly appreciated.
    Many thanks
    I cant find a diagram to compare, also idk if you are still using your Ignition control unit, (the one with all the wires going to it, looks like a small ECU.) but there is a orange and Yellow (O/y) wire coming out of the stock ICU. Its a anti theft wire that ran to the ignition switch, (where the key went), and in the ignition switch is a 100 ohm resistor. so that ground wire needs to feel that resistance to tell the icu to spark.

    I found out after chasing it down for days, not figuring out why I couldn't get spark when it was turning over. Turns out its that 100ohm resistor INSIDE the damn switch. All the wiring diagrams do not show it, so I,m "guessing" it was suzukis attempt a anti theft device. So you cant just clip all the wires and hot wire the thing.

    hope this helps.

    edit: here is the post I found it on. different bike, but it worked for me.
    https://www.gixxer.com/threads/offic...nition.318565/
    Last edited by djMFsnider; 02-27-2020 at 2:17 PM.

Share This



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in