CHOP CULT HOME
Email Password
Search
  1. #1

    Join Date
    Feb 2014
    Posts
    17

    Default 2006 Vstar 650 - carb issues

    Just picked up a 2006 vstar 650 with 11000 miles. Has been sitting for 7 years in a garage but really good condition after a clean up. I drained the tank and oil and new gas and new oil. The bike has vance and hines short shots on it with baffles but hasn't ever been re jetted. My question is the stock mains are 91.3 and the bike idles fine, but is bogging when I try and take off. Once the bike is moving its fine and warmed up. Should I rejet the bike or is it just cold blooded? I live in central valley in california so its not drastic cold. Any help would be greatly appreciated. Im thinking about buying a k&n filter for it as well and want to get it running well before any customizing occurs.

  2. #2
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    May 2012
    Posts
    251

    Default

    Try adjusting your mixture screws and idle. I fiddle with mine between seasons here in aus.

  3. #3

    Join Date
    Feb 2014
    Posts
    17

    Default

    Quote Originally Posted by 21guns View Post
    Try adjusting your mixture screws and idle. I fiddle with mine between seasons here in aus.
    Thanks I will try that tonight. I did drill out the mixture screw caps last night. One thing I did notice was that the front carbs mixture screw was closed all the way so I backed it our 2.5.

Share This



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in