CHOP CULT HOME
Email Password
Search
  1. #1
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Feb 2015
    Posts
    45

    Default Speedometer issues! Send help!

    So, all of my parts for my mini speedometer from J&P cycles arrived earlier this week. I have my cable, 12mm adapter, and the speedo. I got everything mounted and screwed in. I just finished putting the finishing touches, literally 15 minutes ago. I take it for a test right, no luck. I took the small cable that is inside the speedo cable and turned it while it was in the speedo unit. What I can concur from everything is that my cable is either too short, or the wire INSIDE the cable is too short. If anyone has any experience in the area, please help. To go back to the inside cable being too short, I checked both ends, and when the end that connects to the tire module it will seat all the way in properly, but it's the opposite for the speedo unit, the metal cable will not seat all the way inside. I can post pictures if anyone needs, I'll go take them after this post. But I really need help! ASAP!

  2. #2
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Oct 2011
    Posts
    1,897

    Default

    Send it back

Share This



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in