CHOP CULT HOME
Email Password
Search
  1. #1
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jan 2010
    Posts
    50

    Default My Bike: 1976 Kz900ltd "La puta sin nombre"

    [IMG]Photobucket[/IMG]

    [IMG]Photobucket[/IMG]



    Owner name, location: Jason Abbott, Inland Empire- CA

    Bike name if it has one: La puta sin nombre

    Engine, year and make, model, modifications: 1976 Kz900ltd lowered and modified using most of the stock pieces and some spray paint

    Frame: stock, a few cuts here and there

    Fork: stock, lowered

    Chassis mods: chopped back part of frame off, pipe mounts, brackets etc

    Tire/wheel size and style: Stock w/ powdercoat 19/16 Avon Gangster/ speedmaster

    Favorite thing about this bike: the loud ass pipes, it was my uncles and the fact you dont see these much

    Next modification will be: bigbore, port n cams

    Other mods, accessories, cool parts, etc: mx controls, cool seat, reflective graphics

    Any building or riding story or info you'd like to include: This bike was purchased new in 76 by my uncle, he rode it until 94 and parked it with 17k on her. After sitting for 15 years, the last 8 or so of those on the side of the house...I took the ol Kz and gave her a 2nd life last year.......a better life I like to say. With less than $500 and a little spray paint n stickers I made her mine and logged over 8k miles in 2009 including Laughlin NV, Sturgis SD, BigBear and ripping the streets & canyons of So Cal. I like to call her "La puta sin nombre".

    Thanks to: (you may include links to websites here) My uncle for giving me the bike, Wheelspinmx.com, Home Depot for the spraypaint and Rite Aid for the Pabst.
    Last edited by Ghostrider; 01-31-2013 at 5:41 PM.

  2. #2
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jan 2010
    Posts
    50

    Default

    hhhmmmm .......looks like i did somethin wrong when loadin up the pics. ???? I included the link to the pics on this site, is this correct? ChopCult, help a homie out. Thanks

  3. #3
    billdozer
    Guest

    Default

    Here's a demo: http://www.chopcult.com/forum/showth...ight=uploading

  4. #4
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Aug 2009
    Posts
    612

    Default

    Man i really dig your sickle.. How bout some pics of the paint once you figure out how to post pics

  5. #5
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jan 2010
    Posts
    50

    Default

    thanks Billdozer, got pics handled........and thanks for the shout Brandon

Share This



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in