CHOP CULT HOME
Email Password
Search
Page 1 of 2 12 Last
  1. #1
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default XS help in san diego

    im having some wiring issues and im lookin for a pro. anyone who knows the xs 650 inside and out would be greatly appreciated. im up and running but i got no charge. i just wired up my reg/rect and that seems to be in order. i have all the tools and i can come to you. im thinkin it might be the stator rotor? i want to get it done in time for the slab city run so give me a call at 619-997-7286 thanks, scott

  2. #2
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Aug 2009
    Posts
    542

    Default

    A friend of mine just went throw a XS650 charging issue recently, I'll give him a shout and see if he has time to give it a look this week. We are planning to go on the slab city run also.

    Has your wiring been gone through or is it stock? I seem to remember some issue of having to reverse the ground after installing an aftermarket reg/rec...... I could be way off base but I think that was part of the problem on that last XS650
    Last edited by hellbilly1932; 11-08-2009 at 10:19 PM.

  3. #3
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Aug 2009
    Posts
    2,378

    Default

    Not sure if you've been to the Horse website, but I met a guy named Lou that is pretty dialed in. I'll try and make contact with him for you. I personally don't know shit about them or else I'd help you.

  4. #4
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default new

    its a new reg rect on a chopped bike.
    its bare necesseties really. thats why i cant seem to figure out why im having such a hard time hahaha i do have doubts about my stator thiugh. i have 2, one has one of the brushes grounded(the top one.) and one has no grounded brushes at all.

  5. #5
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default thanks.

    ya i would appreciate any help. and somone just text me about a brown wire but i only got half the txt so if you see this send it again thanks!

  6. #6
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default .....

    see this one here, the top one. is grounded but the bottom one is floating. the one on my bike both are floating. no ground to either. the actual housing is different. the whole casting. were there two different years or two models and mabye i have the wrong stator assembley in there?

    [IMG]Photobucket[/IMG]

    [IMG]Photobucket[/IMG]

  7. #7
    chopped850
    Guest

    Default

    Well I wired TemeculaTerry's XS for him. I'm in Temecula and could take a look at it for you. I'm in the process if wiring my norty tomorrow and tues.

  8. #8
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default

    sure. i can come up mabye tues afternoon. i think i might have it though. i might have a 80-84 stator in my 78.... i have a stator i can try and put in tomorrow. i hope thats all it is because everything else seems to be wired right. if it isint that shits gonna start getting expensive

  9. #9
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Aug 2009
    Posts
    66

    Default

    Send me that wad of $100's and I'll give ya the answer.............kidding...............

  10. #10
    Junior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Nov 2009
    Posts
    19

    Default

    with the unit running, check from white to white coming out of the stator and alternating leads. have your voltmeter on ac and you should see 40 volts lead to lead with the plug unplugged (isolated). if you are getting very low voltage, your stator needs to be replaced. it is very rare that a rotor would fail...this is just a hunk of magnet that would only fail if it lost its magnetism.

  11. #11
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    44

    Default

    this might help. make sure your wires are hooked up like this.
    http://www.google.com/imgres?imgurl=...ed=0CAcQ9QEwAA

  12. #12
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default well.....

    fuckin with it earlier i fried my rectifier and i still cant figure out my problem. im ordering a new reg/rect and a stator because i think thats my problem. wish me luck fellas, ima need it if i plan on makin the run this weekend

  13. #13
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    44

    Default

    most likely you have something hooked up wronge. post a pic of your wires in question

  14. #14
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default

    well my biggest issue was and is i dont know witch brush is the positive one. i keep getting mixedmessages from the formus and the fact that there are like 2 or 3 diff stators its hard to keep track. right now i have a 70-79 stator in and theres a top brush (black) and a bottom brush(green) i was under the impression you key switch the positive. when i key switch the black it pops the fuse the min i turn the key. so then i was under the impression that the green was positive, i key'd it and hail mary'd as joel put it and fried my reg/rect.

  15. #15
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default Also.....

    i didnd get a chance to test my white wires b4 it blew.... so im kinda taking a gamble getting a new stator. i know my rotor is good though so i think ima just get both. piece of mind. pricy but at least im at square 1.

  16. #16
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    44

    Default

    not sure but i think your black should go to ground or to the reg ground...imlooking it up right now

  17. #17
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default

    the last move i made was hooking up green brush lead to the key switch and the blue reg/rect lead and the black brush lead to the orange. 3 whites to 3 yellows and the power and ground obviously.... poof! next thing i remember i woke up on the floor and it feels like my wallet got raped hahaha

  18. #18
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Jul 2009
    Posts
    152

    Default

    Hey I'm looking for a bike that's wired and running in the SD area or close that I can mirror. I can't afford to burn anything else up. If you have a xs 650 and a couple hours to kill let me know. I have all my shit. I need and can come to you. Give me a call. 619-997-7286 thanks

  19. #19
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Sep 2009
    Posts
    150

    Default

    75 xs with orig stator/rotor and aftermarket REG/REC off ebay.

    Replaced brush screws with nylon

    stator side --------- reg/rec

    3 Whites -------- 3 yellow
    Green ------------orange
    yellow ----------- cap off
    black -------------blue + switched 12v wire
    Red ---------------batt pos
    Green ------------batt ground

    Very close to this setup:
    Attached Thumbnails Attached Thumbnails noid-chopperwiringdiagram.jpg   noid-stator_screw.jpg  

  20. #20
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Aug 2009
    Posts
    1,000

    Default

    Ah good luck Scottie, this is where I am too. Where's a good place to get a Reg/Recta? Cheapest I can find new ones for is. $99.00 does it get any better?

Share This



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in