CHOP CULT HOME
Email Password
Search
  1. #1
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Nov 2009
    Posts
    80

    Default 68 bsa mag driven

    ok guys i got a 68 bsa firebird scrambler motor, joe hunt mag all new charging system, joe hunt capacitor. pretty bare bones. bike kicks and runs. throttle side cyl runs 100%. clutch side wont fire right.

    mag is new, have 3 sets of new plugs, low brow wires, compression is like 120 both cylinders and recent valve job. its spittin and poppin on the one cyl spittin fuel out. changed carbs from fresh rebuilt chrome 930s to bones stock new 930s...same issue, changed plugs same issue, redid timing 3-4 times same issue.

    i left the plug wires hooked to the plugs and switched connections at the mag. same issue same cylinder. what am i lookin at here? it seems that the lowbrow wires could be the trouble?

  2. #2
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Aug 2009
    Posts
    1,185

    Default

    damn you covered just about all the bases there, swap out the wires with a different set to test or try swapping the whole wire from one cylinder to the other instead of just at the mag end, also although you swapped carbs try switching the cylinder that is running good over to the on that isnt and see if it effects it

    do you feed each carb individually or run a crossover? maybe could be the petcock or the crossover, could try adding a battery to test to see if that helps/changes anything

  3. #3
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Nov 2009
    Posts
    80

    Default

    its a new pingle petcock with new carb bur fittings and new carbs that we completely went through jus to double check. well we switched the mag ends of the wires just to rule out the mag. i got a new set of wires and am gonna be trying that tonight

  4. #4
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Aug 2009
    Posts
    942

    Default

    i'm betting on the carb.

  5. #5
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Nov 2009
    Posts
    80

    Default

    we had a set of chromed 930 new rebuilt on it took them off and put a set of new 930s same issue both sets of carbs

  6. #6
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Aug 2009
    Posts
    1,185

    Default

    so theres only one petcock feeding both carbs? via a crossover tube in the bottom of the bowl- MAYBE the other cylinder is starving for fuel or has an air pocket, im just throwing out ideas, and like i said try swapping the whole wire over if you think its the wires

  7. #7
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Nov 2009
    Posts
    80

    Default

    yea the cylinder is either not gettin enough aprk or too much gas cuz the plus is like soaked. you can take it out and fling off the fuel lol. we are gonna try the new wires after work

  8. #8
    Senior Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Dec 2009
    Posts
    530

    Default

    Have you tried putting a good spark plug in the boot, lay the plug on the head so it will ground and kick it thru. That'll at least tell you if you have fire on that side. Sounds like its getting plenty of fuel, me thinks its the plug wires.

  9. #9
    Member

    Content on this page requires a newer version of Adobe Flash Player.

    Get Adobe Flash player


    Join Date
    Nov 2009
    Posts
    80

    Default

    ok so the problem wasa stuck lifter on that cylinder. had to tear into the top end....by doing so i found a seized ring on that cyl as well so the hung up lifter saved my motor. hopefully we can get away with re-ringin it and massaging the lifter into doin its job.

Share This



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in