PDA

View Full Version : Joe Hunt mag help needed



RetroRob
02-29-2016, 8:30 PM
I've got a Joe Hunt mag on my 49 pan shovel. Ran great last summer, started getting hard to start last fall. Now I kick and get no spark, tested with plug sitting against engine. Removed mag, replaced points and condenser, hooked up to a drill and would spark at higher rpm. Reinstalled, still no spark when kicked. Wires test OK, plugs gapped at .022, point gap .012

Am I dealing with weak magnets ? Bad coil ? Help, can't afford a new mag

docmel
03-02-2016, 1:14 PM
I've got a Joe Hunt mag on my 49 pan shovel. Ran great last summer, started getting hard to start last fall. Now I kick and get no spark, tested with plug sitting against engine. Removed mag, replaced points and condenser, hooked up to a drill and would spark at higher rpm. Reinstalled, still no spark when kicked. Wires test OK, plugs gapped at .022, point gap .012

Am I dealing with weak magnets ? Bad coil ? Help, can't afford a new mag

Mags get a bad rap: Most of the probs you see in mags are that they are installed or set up wrong (they set up exactky like a circuit breaker/distributor), or they are running a mag that is plain worn out

Mags run fine, practically nothing can go wrong, but age, if you have an old one, can play havoc with both the coil, points and magnets. But another issue with old mags are worn shaft bearings, which can cause slight wobble at the points lobe, which will also play havoc with a mag.

Wobble due to worn shaft bushings is a HUGE cause of mags running poorly. It starts out as hardly noticable and tends to get worse over time. Worn shaft bushings cause an uneven turn out of the points lobe, which will cause the points gap to vary as it turns and wobbles, even though you set them right. Signs are harder to start, runs poor at idle, but a little better at higher rpms: Classic signs the shaft bearings are worn.

You can buy the bearings, and even the shaft if need be. Check for wobble by looking at the points lobe while running. You will see the shaft wobble if worn. Better yet, remove the mag, and wobble the shaft at the bottom. Any to and fro play at the point lobe is a sure sign of worn shaft bearings. If this is the case, you can get points, coil and magnets all day long and it wont help

You have done what you can. First step is to replace points and condenser, which you have. All your gap measurements look fine as well

Next is moisture, which will cause probs in a mag

If your bearings are good, I would say its either your coil (available) or magnet (also available): Both of these parts are very easy to replace yourself, and do not cost that much.

If you want your coil completely refurbished, theres a guy that does them up in Wisconsin for about $250

Mags have a magical rep to them, like only a wizard can make them work. They are very easy to work on, with almost no moving parts. Get the parts you need, an exploded diagram view, and you can make it happen

By the way, Joe Hunt, Morse, and other mags almost all use the same exact internal parts

RetroRob
03-02-2016, 1:21 PM
Mags get a bad rap: Most of the probs you see in mags are that they are installed or set up wrong (they set up exactky like a circuit breaker/distributor), or they are running a mag that is plain worn out

Mags run fine, practically nothing can go wrong, but age, if you have an old one, can play havoc with both the coil, points and magnets. But another issue with old mags are worn shaft bearings, which can cause slight wobble at the points lobe, which will also play havoc with a mag.

Wobble due to worn shaft bushings is a HUGE cause of mags running poorly. It starts out as hardly noticable and tends to get worse over time. Worn shaft bushings cause an uneven turn out of the points lobe, which will cause the points gap to vary as it turns and wobbles, even though you set them right. Signs are harder to start, runs poor at idle, but a little better at higher rpms: Classic signs the shaft bearings are worn.

You can buy the bearings, and even the shaft if need be. Check for wobble by looking at the points lobe while running. You will see the shaft wobble if worn. Better yet, remove the mag, and wobble the shaft at the bottom. Any to and fro play at the point lobe is a sure sign of worn shaft bearings. If this is the case, you can get points, coil and magnets all day long and it wont help

You have done what you can. First step is to replace points and condenser, which you have. All your gap measurements look fine as well

Next is moisture, which will cause probs in a mag

If your bearings are good, I would say its either your coil (available) or magnet (also available): Both of these parts are very easy to replace yourself, and do not cost that much.

If you want your coil completely refurbished, theres a guy that does them up in Wisconsin for about $250

Mags have a magical rep to them, like only a wizard can make them work. They are very easy to work on, with almost no moving parts. Get the parts you need, an exploded diagram view, and you can make it happen

By the way, Joe Hunt, Morse, and other mags almost all use the same exact internal parts

Thanks for the reply, I've got the mag out so will check bearings. Talked to an Amish repair shop (for real) that
Really knows these well and thinks it might be the coil. Hope to have them check it out tomorrow.