PDA

View Full Version : xs650 clutch trouble



redsox716
05-14-2010, 3:20 PM
Hey guys. I noticed at the end of last year my clutch was acting strangely. As the bike warmed up I would gain alot of slack in my clutch lever. So when the bike first started from cold my clutch would engage right when I pulled the lever, and by the time the engine warmed up, there was lots of free play in the lever. Any idea what this is a symptom of? This is a new problem. Thanks!

redsox716
05-15-2010, 10:35 AM
Am I an idiot and the answer is painfully obvious, or is everyone else just as stumped as me?

convergecult
05-15-2010, 11:35 AM
I have no idea but I'm very curious. Keep us up to date...

JapJeff
05-15-2010, 2:34 PM
maybe warped clutch plates?

src1981
05-18-2010, 7:39 PM
i have a simalar problem ......im going to replace the fibers and install heavy duty clutch springs.....

Punkskalar
06-04-2010, 1:31 PM
you probably have the 2 piece plus 2 bearings style clutch rod... Upgrade to the earlier style 1 piece clutch rod and it will help a ton....

MikesXS carries them...

justinspace
06-04-2010, 3:10 PM
i dont think the heavy duty clutch springs are the solution. thats more for high powered engines. like adding the 750 kit...which may make your clutch slip. so you would need the better springs to keep it all engaged...
i used the one pc pushrod and it helped out a lot. especially finding neutral. also the easy pull cable...(maybe im not completly sold on the idea) and i also use a msr perch with quick adjust. it has a nice throw on the lever. and there is also a mod you can do to your lever on the worm gear under the case cover. extend it out about a half inch.