PDA

View Full Version : 1982 KZ1000 LTD clutch problem



LoneStarr666
02-04-2015, 11:11 AM
I have a 1982 kz1000 that i just bought for 800 dollars. It has not ran in about 6 months. The previous owner had taken it apart to replace the stator and never put it back together. I got it and put the stator back on some new gas and had it running in no time. The problem I am having is with the clutch. I adjust it according to the manual. Pull the lever in and I hear a pop and lose all tension on the lever. I noticed it is popping out at the sprocket cover. I know clutch plates have a tendency to stick together after not being in use for an amount of time. So what Im thinking is they are so stuck together that pulling the lever is not enough to spread them apart. Any help on this would be appreciated before I start pulling the clutch basket apart.

wagonmaster69
02-08-2015, 9:00 PM
Go to kzrider.com somebody there should be able to help you.

royota
02-10-2015, 10:35 AM
56538
If this is how your clutch is the piece 13102 rotates and presses on part 13119 which presses the rod Into the clutch. If it is adjusted too tight it will pop off the bearings and lose all tension.

Wolfie
02-10-2015, 6:54 PM
If you put synthetic in it, yer gonna have issues...wet clutches dont like it.....drain yer oil and try a Castrol GTX...its all Ive used in all my bikes since the 60s....

There's another issue with Kawi clutches...if you run shit oil, the metal plates can get glazed easily (crappy Jap steel).....take the clutch apart, and deglaze the steel plates with some thinner and steel wool....

...another more radical fix is to drill holes in the clutch housing....for better oil flow....save that one for last.....