PDA

View Full Version : Oil pump issues



sumdumdiver
06-21-2014, 9:26 PM
Oil just started dumping between the pump body and pump cover on a 73 flh I figured it was time for gaskets. Did the gaskets and put it back together and still pouring through the gasket between pump body and cover. Everything is plumbed correctly and I get good return back to the oil tank. I am assuming its the breather gear as I am building pressure in the pump and it doesn't seem to be purging itself on the floor. Screwing around with it today I blew out all the lines checking for blockages, everything is wide open but realized I am not getting any flow to the primary as well. It doesn't even want to feed the primary. The breather gear kind of makes sense as to the build up of pressure but the no flow to the primary has me a little confused with no detectable blockages.

Any ideas, theories?

Sky
06-22-2014, 12:29 PM
Sometimes it's tricky to choose the correct oil pump gaskets. People swap years and there's aftermarket stuff too.
Also a later pump needs an extra passage drilled into the cases. There are fixtures for this operation.
An oil passage might be blocked somewhere. In the case or tappet blocks even. At the head gasket? Oil lines to the rocker-boxes? Shafts or rockers themselves?
Check the tappet screen? Is the pressure relief plunger free to move? the spring too stiff?
I like to isolate the primary anyway. And capping the primary feed and return should not cause any pressure related problems.

BuddhahoodVato
06-22-2014, 7:16 PM
Your spring or ball bearing is not sitting well in the, fuck now I forget the definition. that's why it's purging on the floor, dam it's the top screw on the pump, pull it, clean it, stretch the spring a grunion, check the ball bearing.
but also the previous solution is also a option.