PDA

View Full Version : i need help sportster wont start



jrb
03-30-2013, 6:16 PM
i need some help. i have a 86 sportster that wont start i hit the starter button an it just cranks until it kills the battery but wont start. can someone help me out. the starter sounds good it started yesterday with no prob. but started today for about 5 min and back fired an now it just cranks.

vnygra
03-30-2013, 6:23 PM
Have gas in it? Check for spark?

paulw
03-30-2013, 6:33 PM
check the battery connection, similar thing happen to me, i tightened the terminals and i was good to go

lowlife32
03-30-2013, 6:34 PM
Checked your wires from the module to the coil?

Gnarly
03-30-2013, 7:02 PM
Coil wire shakes off my ironhead when it idles....

Shrugsmoto1
03-30-2013, 7:40 PM
I would check fuel first. Do you smell gas after it has been cranking? If you have the stock petcock pull that and check the in tank mesh filter.

jrb
03-30-2013, 9:58 PM
thanks it has gas and spark. im running down the list on the prob. no luck yet. im gonna adjust points in the am

backwithabang
03-31-2013, 12:05 AM
sporty issues, from my evil real life experiences

cold weather climates yanking their bikes out of the garage for spring, check your valve adjustments, heating/cooling on those rods fucks shit up

gas, air- basic make sure you got both

spark, easy enough to check

electrical, double check your connections as said previously. starter relays, if that starter is cranking and your cel isnt engaging no go, with that said, could be a bad bearing in the starter gearing. or just a bad connection in the cel/starter/relay wiring

shit gas

shit venting on your gas cap.

shit coil

points out of wack

timing off

vnygra
03-31-2013, 12:06 AM
Yea if ya definitely have gas and spark it should be timing thing. One thing I had happen before was the pin that is on the advance plate snapped. Took forever to locate that shit. Same thing was happening. Gas, spark, points didn't move. Fuckin pin.

treebeard
08-31-2015, 11:42 AM
had the same issue on my efi sporty. went through relays, checked for gas smell, etc. Problem ended up being the push collar which seats the fuel line to the fuel pump unhinged which disconnected the fuel line even though it still appeared connected. all these shit nyc streets must have unseated it. so add that to the checklist.

jd