PDA

View Full Version : 68 Bonnie putters out in 4th



backwithabang
07-03-2012, 9:48 AM
Seems to run great as long as I'm not hitting around 65-70 at a full throttle. She just gives a quick sputter and shuts down on me.

Thinking it has to be carb related of course, running vm32s off a BSA. Starved for fuel? If that's the case I'll just switch back to Amal 932s.

Only other weird thing on the bike is a 13th clutch plate (stuffer plate). And a backwards geared right side shift with neutral in the correct place. Oh and a 71 top with a 750 kit. Seems it was made to be dangerous back in the day. also came with a fiberglass tank originally

I'm not really in the mood to play the jet /needle game with mikunis as that sucks major shit. So unless you guys know another major reason why this would happen besides a lack of fuel when it's hauling ass. I'll just go back to amals

CRFyou
07-03-2012, 9:56 AM
a lack of fuel when it's hauling ass. I'll just go back to amals

go back to amals. you need the large float bowl(s).

backwithabang
07-03-2012, 2:33 PM
Agreed. These little jap bitches are finicky.

dazegoneby
07-04-2012, 6:54 AM
possible petcock cloggining?also think amals only choice for a trump,,,once dialed in work good

Torch
07-04-2012, 8:37 AM
check the air bleed hole on the top of the gas cap to see if it's blocked.

61xlh
07-04-2012, 12:51 PM
had that problem. go back to an amal, and put a dual feed inlet on the bottom of the float bowl.
run two pet cocks.
there is, im sure, an easier answer, but it worked for me.
brit bikes came with amals.
a buddy of mine runs one on his ulh.

backwithabang
07-04-2012, 1:00 PM
Dual carbs I need to get two. Had two but they burned.

The gascap was old I switched it out seems to run a bit better.

I am going to go back to the amals though. Looks like lowbrow is getting more of my money