PDA

View Full Version : triumph wiring trouble



deadfink138
07-02-2012, 4:21 PM
looking for some help with wiring on my 650 triumph trying to do a batteryless system with a pazon ignition, i used the diagrams from lowbrow and that came with the pazon unit. when im trying to kick it over im getting no spark looking for some advice on the system, any help will be very apperciated, thanks chris

slickpaint999
07-02-2012, 4:47 PM
Im no expert at all, but just went thru the wringer with the same setup. For what its worth, I have a new "highoutput" Wassel rotor / stator from Lobrow , a Sparx battery eliminator, Pazon E I, and an L E D taillight. after lots of mayhem, the last thing I did to make it all run / work, was the L E D taillight bulb. Also, ANY bare wire grounding out will kill the bike. Just an FYI

davesidfab
07-02-2012, 5:06 PM
i went through it all too,go through the process of elimination with a muiltimeter, start by check for basics like power and a ground. thats really will sum up most of what anyone will really be able to tell ya over the web?

RetroRob
07-02-2012, 5:10 PM
Check to make sure your getting output from the stator, then check the wires to the Sparx, make sure all connections are good and you have a good ground. Make sure your toggle switch / key switch is on nd wired correctly. Check for spark by removing the plug and touching it against the head while kicking. If you have spark move on to timing,if not probably the rotor stator.

dazegoneby
07-02-2012, 8:36 PM
here are a few wireing diagrams ,,,hope they help27408

27409

dazegoneby
07-02-2012, 8:39 PM
one more