PDA

View Full Version : Starting to work on a 69 ironhead, what to check out first??



opposed
11-04-2009, 10:16 AM
So, I just picked up this '69xlch in a rigid frame, new paint,yadyada. Anyway, the old timer says the motor was rebuilt( every motor is right!), but he had a stack of receipts that was pretty thick and the motor is spotless. But the motor was rebuilt and not fired about 7 years ago. It turns over nicely and all seems to be in order,but just to be on the safe side I want to dial in in first. My questions are, since I'm a jap/euro bike guy, what should I check before attempting to get it fired?? I'm gonna time the cams and magneto, then adjust the valves, adjust the clutch and retorque all of the criticals. What else should I do??? Thanks

dirtyd
11-05-2009, 10:27 AM
put fresh oil in drain the old stuff out. check on the carb to make sure it isnt gunked up or plugged up. It sucks to dryfire and then have your bike running shitty because carb is all plugged etc. Id spray some ( a little ) lube in the cylinders and kick em through a bit just to make sure the rings arent stuck. fresh gas , and fire her up. be nice to it while its heating up. go soft on the throttle for a little while to get the blood pumping on her. check your oil pressure. run her a bit shut her down. recheck everything. And if alls well break her in properly. It should be good to go. Oh check your tranny and primary side too. You may notice the clutch isnt grabbing real good. well after sitting for all those years in a oil bath the plates get funky. no biggie though. Good luck man. post up bro !!

mjasen10
11-05-2009, 4:58 PM
i think dirtyd pretty much covererd everything

chopped850
11-07-2009, 9:39 PM
If your clutch plates are stuck together I highly recommend making a spring compressor or buy one. There are two giant ass conical springs under that pressure plate and will break shit if you try backing off the nuts. Ask me how I know this. But sitting 7 years it should be fine. My 73' XLCH sat for 20 years. I had the front exhaust cam out of timing and kicked that bitch for a month and 2 carbs until I figured it out. Change the fluids, and other stuff mentioned. Get it running and put the front wheel against the garage door frame and put the bike in gear. If it chirps the tire and dies then the clutch plates are glued to each other. If it keeps running then it should be okay.